NS-Purchase Order Error: Invalid Number (must be positive)
NOTE: The warehouse CANNOT perform the below resolution. IT Applications Support must perform this task to clear the error.
Description of Issue:
When posting a purchase order on a scan gun, the following order is encountered, "Invalid Number (must be positive)". This is due to a WMS Open Task having an actual quantity of 0.
Once the WMS Open Task with quantity of 0 has been removed from the PO, the warehouse can post the receipt through the scan gun.
Issue:
The warehouse will receive "Error: Invalid Number (must be positive) when attempting to post a receipt of a PO through the scan gun.
Cause:
This is caused when there is a WMS Open Task with an Actual Quantity of 0.
This error means that the DC tried to receive an item on a PO and realized they did not receive the item so they skipped it. This process creates a 0 line.

Resolution Steps:
Open the PO > Click on NS WMS > Click on WMS Open Task
- Locate the 0 item
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Ask the DC if they received this item physically
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If yes. review the Open WMS Task to see if the item has 2 lines one with a qty and one without a qty (Screen shot below has 2 lines)
- IF there are 2 remove the 0 line
- If there is only 1 line, then Edit and add the qty the DC physically received to the line
-
If no, Remove the 0 line
- Scroll all the way to the right and Click "Remove" to remove the line
Once the above steps have been completed, the warehouse can post the receipt in the Scan Gun.